You are here: Support Center » TradeTrakker Support » TradeTrakker System Require...

TradeTrakker System Requirements

Basically any computer sold during the last 5 years and running any modern version Microsoft Windows should have no problem running our software:

Supported Operating Systems

TradeTrakker has been tested and fully supports the following Microsoft operating systems:

  • Microsoft Windows 10
  • Microsoft Windows 8.1
  • Microsoft Windows 8
  • Microsoft Windows 7
  • Microsoft Windows Vista
  • Microsoft Windows XP SP3

TradeTrakker has been tested and is supported on both 32-bit and 64-bit Windows (any version from the list above).

Last updated by haim on November 18, 2014 12:04